Документация/Статьи/Обзор Deployment Tool

From NeoAxis 3D Engine Wiki

Jump to: navigation, search
Перейти на уровень выше

Contents

Описание

DeploymentToolIcon.jpg Инструмент для подготовки конечного продукта (DeploymentTool.exe) — утилита, предназначенная для сборки конечной версии приложения для определенной платформы. Данный инструмент полезен для автоматизации процесса подготовки конечного продукта.

В конце данной статьи приводится урок по сборке готового пакета, в котором дана пошаговая инструкция по использованию Deployment Tool.

DeploymentTool 01.jpg

Вкладка General

Во вкладке General расположены основные настройки.

Свойство Описание
Output Directory Директория для готового проекта. В эту директорию будут скопированы файлы проекта.
Destination Platform Целевая платформа. Пока предлагается выбрать между Windows и Mac OS X. В будущем будут добавлены и другие платформы.
Include 32-bit binaries Включать ли в проект 32-битные исполняемые файлы.
Include 64-bit binaries Включать ли в проект 64-битные исполняемые файлы.
Application Directory Директория приложения. Этот параметр позволяет указать название директории с пользовательскими файлами, которая будет создана после того, как пользователь установит приложение на свой компьютер.
Data Directory Archivation Архивировать ли папку Data. Если флажок выставлен, то все ресурсы будут помещены в zip-архив.
Default Language Язык, используемый по умолчанию. Предлагается выбрать язык из списка. Если выбран параметр Autodetect, то язык будет выбираться автоматически, на основе настроек системы пользователя.

Вкладка Components

На вкладке Components можно выбрать, какие компоненты движка войдут в готовый проект. Можно выбрать, какие библиотеки и составные части движка нужны, а какие нет. Рекомендуется отметить только те компоненты, которые будут использоваться.

DeploymentTool 02.jpg

В таблице ниже показано, какие компоненты можно выбрать для той или иной платформы.

Имя Описание Win x86 Win x64 Mac OS X
Application_Configurator Утилита для настройки движка
Yes.jpg
Yes.jpg
No.jpg
Application_DedicatedServer Выделенный сервер.
Yes.jpg
Yes.jpg
No.jpg
Application_Game Исполняемый файл проекта. Точка входа в приложение, инициализация движка, классы для реализации структуры проекта, навигации игровых экранов и взаимодействия с пользователем.
Yes.jpg
Yes.jpg
Yes.jpg
Archive_ZIP Поддержка работы с zip-архивами.
Yes.jpg
Yes.jpg
Yes.jpg
Entity_DecorativeObjectManager Менеджер декоративных объектов. Обеспечивает рисование большого числа маленьких трехмерных объектов. Подробное описание находится здесь.
Yes.jpg
Yes.jpg
Yes.jpg
Entity_GridBasedNavigationSystem. Система поиска пути, использующая двумерную сетку.
Yes.jpg
Yes.jpg
Yes.jpg
Entity_HeightmapTerrain Ландшафты на основе карты высот.
Yes.jpg
Yes.jpg
Yes.jpg
Entity_RecastNavigationSystem Система поиска пути, использующая навигационную сетку.
Yes.jpg
Yes.jpg
Yes.jpg
GUIControl_WebBrowserControl Веб-браузер, встраиваемый в пользовательский интерфейс.
Yes.jpg
Yes.jpg
Yes.jpg
ImportingModel_ASSIMP Поддержка библиотеки Open Asset Import Library для импорта в движок трехмерных моделей. Подробно об импорте моделей в движок написано здесь.
Yes.jpg
Yes.jpg
No.jpg
ImportingModel_FBX Поддержка формата FBX от компании Autodesk. Подробно об импорте моделей в движок написано здесь.
Yes.jpg
Yes.jpg
No.jpg
MapEditorAddon_ExampleAddonCreation Пример дополнения для редактора карт.
Yes.jpg
Yes.jpg
No.jpg
MapEditorAddon_ExportTo3DModel Дополнение для редактора карт, позволяющее экспортировать выбранные объекты карты в единую трехмерную модель.
Yes.jpg
Yes.jpg
No.jpg
PhysicsSystem_ODE Физическая подсистема на основе библиотеки Open Dynamics Engine.
Yes.jpg
Yes.jpg
Yes.jpg
PhysicsSystem_PhysX Физическая подсистема на основе библиотеки PhysX от компании NVIDIA.
Yes.jpg
Yes.jpg
Yes.jpg
ProjectCommon Библиотека, включающая различные классы проекта, такие как, описание типов материалов, сетевые сервисы, класс консоли движка, пользовательские GUI-классы и многие другие.
Yes.jpg
Yes.jpg
Yes.jpg
ProjectEnities Библиотека, включающая описание различных игровых классов.
Yes.jpg
Yes.jpg
Yes.jpg
RenderingSystem_Direct3D9 Система рендеринга на основе Direct3D9.
Yes.jpg
Yes.jpg
No.jpg
RenderingSystem_NULL Пустая система рендеринга. Может быть использована в серверном приложении.
Yes.jpg
Yes.jpg
No.jpg
RenderingSystem_OpenGL Система рендеринга на основе OpenGL.
Yes.jpg
Yes.jpg
Yes.jpg
ResourceEditorAddon_ExampleAddonCreation Пример дополнения для редактора ресурсов.
Yes.jpg
Yes.jpg
No.jpg
SoundSystem_DirectSound Звуковая подсистема на основе DirectSound.
Yes.jpg
Yes.jpg
No.jpg
SoundSystem_NULL Пустая звуковая подсистема.
Yes.jpg
Yes.jpg
Yes.jpg
SoundSystem_OpenAL Звуковая подсистема на основе OpenAL.
Yes.jpg
Yes.jpg
Yes.jpg
StaticLightingCalculation_Simple Простая система расчета статичного освещения.
Yes.jpg
Yes.jpg
No.jpg

Вкладка Additional Files

На этой вкладке можно указать те библиотеки и файлы, которые не являются зарегистрированными компонентами (например, собственные компоненты пользователя). Они будут экспортированы вместе с проектом.

DeploymentTool 03.jpg

Вкладка File Exceptions

На данной вкладке предлагается указать файлы, которые будут исключены из готового проекта. В первом поле через точку с запятой вводятся расширения файлов, которые не требуется включать в проект. Во втором поле построчно указываются отдельные исключаемые файлы или папки.

DeploymentTool 04.jpg

Вкладка Build Events

Тут можно задать команды, которые будут выполнены в процессе подготовки проекта. Команды используют командную строку Windows (.cmd, .bat файлы).

В первое поле вводятся команды, которые будут выполнены после копирования файлов. Во втором поле указываются команды, которые будут выполнены после завершения подготовки проекта. В командах допустимо использование макросов. Список макросов можно посмотреть, нажав кнопку Macros.

DeploymentTool 05.jpg

Меню Deployment Tool

Меню File

DeploymentTool 06.jpg

В меню File можно найти следующие пункты:

Название Описание
New Создание нового проекта.
Open Открытие сохраненного проекта.
Save Сохранение настроек данного проекта. Доступно по сочетанию клавиш Ctrl+S.
Save As... Сохранение настроек проекта с предварительным выбором имени и директории файла настроек.
Exit Выход из утилиты.

Меню Build

DeploymentTool 07.jpg

В меню Build содержится единственный пункт "Deploy...", который запускает сборку проекта — копирование нужных файлов в выбранную директорию, с учетом всех настроек.

Меню Help

DeploymentTool 08.jpg

В меню Help можно найти следующие пункты:

Название Описание
Overview of the Deployment Tool Открытие описания утилиты, т.е. этой статьи.
Documentation Открытие заглавной страницы документации.
About... Открытие стандартного окна "О программе".

Верхняя панель

DeploymentTool 09.jpg

В верхней панели расположены кнопки быстрого запуска в следующем порядке:

  • New — создание нового проекта,
  • Open — открытие сохраненного ранее проекта,
  • Save — сохранение проекта,
  • Deploy — сборка проекта.

Урок — Сборка готового пакета для обычного приложения

В этом небольшом уроке мы научимся собирать готовый пакет.

Перед тем как приступить к сборке готового пакета, скомпилируйте ваш проект. А также, желательно перекомпилировать кеш шейдеров.

Теперь приступим к сборке. Запустим Deployment Tool.

Вкладка General

Для начала укажем директорию для сохранения готового пакета. Для этого нажмем на кнопку "..." рядом с полем Output Directory и выберем директорию.

Затем выберем целевую операционную систему: Windows. Остальные параметры оставим со значениями по умолчанию.

Использование тех или иных платформ может отразиться на настройке компонентов.
DeploymentTool 10.jpg
Если вы используете 64-битную платформу Windows, то не забудьте скомпилировать ваш проект в конфигурации Any CPU.

Вкладка Components

Компоненты для сборки выбираются исходя из нужд вашего проекта и руководствуясь возможностями целевой платформы. В рамках данного урока оставим настройки компонент без изменения.

Список доступных для различных платформ компонентов можно посмотреть в данном разделе.

DeploymentTool 11.jpg

Сборка

Сохраним настройки с помощью меню File -> Save.

Приступим к сборке. Выберем пункт Deploy в меню Build.... Появится окно с вопросом об очистке директории пакета. Прежде чем нажать кнопку Yes, убедимся, что директория пакета (Output directory) пуста.

DeploymentTool 12.jpg

После этого появится окно со списком выполненных действий. По завершению сборки нажмем кнопку Close.

DeploymentTool 13.jpg

На этом сборка готового пакета завершена.