Документация/Статьи/Обзор редактора ресурсов

From NeoAxis 3D Engine Wiki

Jump to: navigation, search
Перейти на уровень выше

Contents

Описание

ResourceEditorIcon.jpg Редактор ресурсов (ResourceEditor.exe) — инструмент для управления ресурсами проекта. Редактор включает в себя возможность настройки 3D моделей, материалов, текстур, физических моделей, пользовательских интерфейсов, типов объектов и другое.

ResourceEditor 001.jpg

Все ресурсы располагаются в папке Data проекта, каждый из них представлен одним файлом. Ресурсы делятся на следующие виды:

  • тип объекта — .type;
  • 3D модель — .mesh;
  • физические модель — .physics;
  • материала — .highMaterial;
  • текстура — .dds, .jpg, .png, .tga, .bmp, .hdr и другие;
  • интерфейс — .gui;
  • система частиц — .particle;
  • описание шрифта — .fontDefinition;
  • звук — .ogg, .wav;
  • видео — .ogv, .ogg;
  • файл настроек импорта 3D моделей — .modelImport.

Общий вид

Окно редактора включает в себя следующие части:

  1. Верхняя панель — меню и панель инструментов.
  2. Окно ресурсов — дерево всех ресурсов.
  3. Окно свойств — окно свойств выделенных объектов.
  4. Рабочая область — окно для редактирования объектов с помощью визуальных средств.
ResourceEditor 002.jpg

Работа с редактором

Редактор ресурсов представляет собой набор специализированных редакторов, служащих для работы с различными ресурсами. При этом управление в редакторах, где задействована рабочая область, остается единым.

Управление камерой

Помимо режима обычной камеры, в редакторе имеется режим свободной камеры. Чтобы включить режим свободной камеры, можно воспользоваться соответствующими пунктами меню Edit или кнопками на панели инструментов. Режим камеры выбирается отдельно для просмотра и для редактирования ресурса.

Управление камерой в обычном режиме

Перемещение по рабочему пространству в редакторе осуществляется с помощью следующих клавиш:

  • W — поворот камеры вниз,
  • A — поворот камеры влево,
  • S — поворот камеры вверх,
  • D — поворот камеры вправо,
  • Q — приближение камеры,
  • E — удаление камеры.

Нажатие и удержание клавиши Shift позволяет вращать камеру быстрее.

При нажатой правой кнопки мыши камера поворачивается вслед за перемещаемым курсором. При прокручивании колесика камера приближается, либо удаляется.

Управление камерой в свободном режиме

Перемещение в редакторе осуществляется с помощью следующих клавиш:

  • W — движение вперед,
  • A — движение влево,
  • S — движение назад,
  • D — движение вправо,
  • Q — движение вверх,
  • E — движение вниз.

Нажатие и удержание клавиши Shift позволяет перемещаться по карте быстрее.

При нажатой правой кнопки мыши камера поворачивается вслед за перемещаемым курсором. При этом камера зафиксирована в одной точке. При нажатой средней кнопки мыши и движении мыши камера перемещается в соответствующем направлении, аналогично кнопкам A и D. При движении мыши вверх-вниз камера перемещается вверх-вниз, аналогично клавишам Q и E. При этом камера смотрит прямо и не поворачивается.

Инструмент трансформации

Такие элементы как прикрепляемые объекты в редакторе типов, тела в редакторе физических моделей, источники частиц в редакторе систем частиц, источники мешей в редакторе импорта моделей обладают свойствами, задающими положение элемента в пространства. К этим свойствам относятся позиция, поворот и масштабирование. Для редактирования данных характеристик можно воспользоваться соответствующими полями в окне свойств — Position, Rotation и Scale. Но редактирование положения объектов удобнее выполнять с помощью визуальных средств. Для этого нужно использовать инструмент трансформации.

ResourceEditor 039.jpg

За каждую из трех характеристик объекта отвечает собственный тип инструмента трансформации:

ResourceEditor 040.jpg

Выбрать инструменты можно через главную панель или меню Edit.

Перед тем, как положение какого-то объекта или объектов может быть изменено, он или они должны быть выбраны. Режим выделения объектов работает и при включенном инструменте трансформации, так что выбрать объект можно после выбора инструмента трансформации.

Инструмент трансформации позиции

ResourceEditor 041.jpg

Инструмент трансформации позиции служит для изменения позиции объекта, задающейся свойством Position. Данный инструмент представляет собой три ортогональных оси — X, Y, Z.

ResourceEditor 042.jpg

Чтобы изменить одну из компонент позиции объекта (X, Y или Z), необходимо зажать левую кнопку мыши на соответствующей оси и потянуть за нее в нужную сторону. После изменения компоненты, левую кнопку мыши нужно отпустить.

ResourceEditor 043.jpg

Наведя курсор на одну из граней, образуемой парами осей инструмента трансформации, и потянув за нее, можно изменить сразу две компоненты позиции объекта.

В панели инструментов можно найти дополнительные опции для перемещения объектов:

  • Movement Snapping — изменение позиции с заданным шагом,
  • Move Objects Using Local Coordinates — использование локальных координат при перемещении объекта.

Подробную информацию об этих кнопках можно получить в разделе описания панели инструментов.

Инструмент трансформации поворота

ResourceEditor 044.jpg

Инструмент трансформации поворота служит для изменения поворота объекта, задающегося свойством Rotation. Данный инструмент представляет собой сферу, образованную тремя окружностями, каждая из которых соответствует одной из осей координат. Также в инструмент поворота входит дополнительная окружность, расположенная в плоскости, перпендикулярной направлению камеры.

ResourceEditor 045.jpg

Чтобы повернуть объект по одной из осей (X, Y или Z), нужно потянуть за соответствующую окружность сферы инструмента трансформации.

ResourceEditor 046.jpg

Дополнительная окружность, перпендикулярная направлению камеры, окрашена в серый цвет. Потянув за нее, можно изменить поворот объекта по оси, соответствующей текущему направлению камеры.

ResourceEditor 047.jpg

Кроме того, можно поворачивать объект сразу по нескольким осям. Для этого нужно навести курсор и тянуть за круг в центральной части инструмента трансформации.

В панели инструментов можно найти дополнительные опции для поворота объектов:

  • Rotation Snapping — изменение поворота с заданным шагом,
  • Move Objects Using Local Coordinates — использование локальных координат при повороте объекта,
  • Move Objects During Rotation — перемещение объектов, во время поворота группы объектов.

Подробную информацию об этих кнопках можно получить в разделе описания панели инструментов.

Инструмент трансформации масштабирования

ResourceEditor 048.jpg

Инструмент трансформации масштабирования служит для изменения масштабирования объекта, задающимся свойством Scale. Данный инструмент представлен, соединенными между собой, тремя ортогональными осями — X, Y, Z.

ResourceEditor 049.jpg

Чтобы изменить одну из компонент масштабирования объекта (X, Y или Z), нужно потянуть за соответствующую ось инструмента трансформации.

ResourceEditor 050.jpg

Все оси инструмента трансформации соединены попарно. Потянув за грань, можно изменить сразу две компоненты масштабирования объектов.

ResourceEditor 051.jpg

Кроме того, потянув за треугольник в центральной части инструмента трансформации, можно симметрично масштабировать объект по всем трем осям.

В панели инструментов можно найти дополнительные опции для масштабирования объектов:

  • Scaling Snapping — изменение масштабирования с заданным шагом,
  • Move Objects During Scaling — перемещение объектов, во время масштабирования группы объектов.

Подробную информацию об этих кнопках можно получить в разделе описания панели инструментов.

Меню

Название Описание
New Создать новый ресурс.
Import 3D Models... Быстрый импорт 3D моделей,подробнее Здесь.
Edit Перейти в режим редактирования ресурса.
Close Editing Выйти из режима редактирования.
Save Сохранить ресурс.
Reload Resource Editor Перезагрузить редактор.
Exit Закрыть редактор.
ResourceEditor 003.jpg



Название Описание
Undo Отменить последнее действие.
Redo Повторить отмененное действие.
Select Включить режим выделения объектов.
Move Включить режим выделения и перемещения объектов. В данном режиме можно двигать объекты с помощью инструмента трансформации.
Rotate Включить режим выделения и вращения объектов. В данном режиме можно вращать объекты с помощью инструмента трансформации.
Scale Включить режим выделения и масштабирования объектов. В данном режиме можно масштабировать объекты с помощью инструмента трансформации.
Movement Snapping Включает/выключает режим пошагового перемещения объектов. Перемещение осуществляется с фиксированным шагом. Шаг указывается в опциях.
Rotation Snapping Включает/выключает режим пошагового поворота объектов. Поворот осуществляется с фиксированным шагом. Шаг указывается в опциях.
Scaling Snapping Включает/выключает режим пошагового масштабирования объектов. Масштабирование осуществляется с фиксированным шагом. Шаг указывается в опциях.
Move Objects Using Local Coordinates Включает/выключает режим перемещения и вращения объектов в локальных координатах объекта. В этом режиме направление осей инструмента трансформации объектов будет в локальных координатах объекта, а не в мировых координатах.
Move Objects During Rotation Включает/выключает режим перемещения объектов во время поворота. Если опция выбрана, то поворот группы выбранных объектов осуществляется относительно центра всей группы. Соответственно, меняются координаты объектов. Если же опция выключена, то поворот каждого объекта в группе выбранных происходит относительно собственного центра объекта. Таким образом, координаты объектов остаются неизменными.
Move Objects During Scaling Включает/выключает режим перемещения объектов во время масштабирования. Если опция выбрана, то масштабу подвергаются не только сами объекты из группы выбранных, но и их координаты относительно центра группы. Если же опция выключена, то масштабирование координат выбранных объектов не осуществляется.
Clone Клонировать выделенные объекты.
Delete... Удалить выделенные объекты.
Free Camera Mod For Viewing Включить/выключить режим свободной камеры при просмотре ресурсов.
Free Camera Mod For Editing Включить/выключить режим свободной камеры при редактировании ресурсов.
ResourceEditor 004.jpg


Название Описание
Resources Window Показать/скрыть дерево ресурсов.
Properties Window Показать/скрыть окно свойств.
Output Window Показать/скрыть окно вывода.
Reset Window Settings Сбросить оконные настройки.
Toolbar Настроить положение панели инструментов. Предлагается разместить панель сверху, снизу, слева, справа или убрать панели.
Status Bar Показать/скрыть строку состояния.
Full Screen Mode Перейти в полноэкранный режим.
ResourceEditor 005.jpg


Название Описание
Example of Add-on Creation Пример дополнения для редактора.
ResourceEditor 007.jpg


Название Описание
Open Map Editor Открыть редактор карт.
Run Simulation Запустить симуляцию. Открывается Game.exe. Параметры запуска можно указать в настройках.
Options... Открыть настройки редактора.
ResourceEditor 008.jpg



Название Описание
Overview of Resource Editor Открыть описание редактора ресурсов, т.е. этой статьи.
Documentation Открытие заглавной страницы документации.
About... Открытие окна "О программе".
ResourceEditor 009.jpg


Панель инструментов

ResourceEditor 010.jpg
Название Описание
1. Import 3D models Быстрый импорт 3D моделей.
2. New Folder Создать новую директорию.
3. New Resource Создать новый ресурс.
4. Edit Перейти в режим редактирования ресурса.
5. Close Editing Выйти из режима редактирования.
6. Save Сохранить ресурс.
7. Undo Отменить последнее действие.
8. Redo Повторить отмененное действие.
9. Select Включить режим выделения объектов.
10. Move Включить режим выделения и перемещения объектов. В данном режиме можно двигать объекты с помощью инструмента трансформации.
11. Rotate Включить режим выделения и вращения объектов. В данном режиме можно вращать объекты с помощью инструмента трансформации.
12. Scale Включить режим выделения и масштабирования объектов. В данном режиме можно масштабировать объекты с помощью инструмента трансформации.
13. Movement Snapping Включает/выключает режим пошагового перемещения объектов. Перемещение осуществляется с фиксированным шагом. Шаг указывается в опциях.
14. Rotation Snapping Включает/выключает режим пошагового поворота объектов. Поворот осуществляется с фиксированным шагом. Шаг указывается в опциях.
15. Scaling Snapping Включает/выключает режим пошагового масштабирования объектов. Масштабирование осуществляется с фиксированным шагом. Шаг указывается в опциях.
16. Move Objects Using Local Coordinates Включает/выключает режим перемещения и вращения объектов в локальных координатах объекта. В этом режиме направление осей инструмента трансформации объектов будет в локальных координатах объекта, а не в мировых координатах.
17. Move Objects During Rotation Включает/выключает режим перемещения объектов во время поворота. Если опция выбрана, то поворот группы выбранных объектов осуществляется относительно центра всей группы. Соответственно, меняются координаты объектов. Если же опция выключена, то поворот каждого объекта в группе выбранных происходит относительно собственного центра объекта. Таким образом, координаты объектов остаются неизменными.
18. Move Objects During Scaling Включает/выключает режим перемещения объектов во время масштабирования. Если опция выбрана, то масштабу подвергаются не только сами объекты из группы выбранных, но и их координаты относительно центра группы. Если же опция выключена, то масштабирование координат выбранных объектов не осуществляется.
19. Clone Клонировать выделенные объекты.
20. Delete Удалить выделенные объекты.
21. Use Free Camera Mode for Viewing Включить/выключить режим свободной камеры при просмотре ресурсов.
22. Use Free Camera Mode for Editing Включить/выключить режим свободной камеры при редактировании ресурсов.
23. Options Открыть настройки редактора.
24. Reload Resource Editor Перезапустить редактор ресурсов.
25. Open Map Editor Открыть редактор карт.
26. Run Simulation Запустить симуляцию. Открывается Game.exe. Параметры запуска можно указать в настройках.

Окно ресурсов

В окне ресурсов располагается дерево файлов и каталогов папки Data проекта. В этом окне выбирается ресурс для просмотра или редактирования. Различные типы ресурсов упорядочены по папкам. При разработке проекта рекомендуется придерживаться систематизации размещения ресурсов. Альтернативный вариант — создать отдельную папку для всех ресурсов проекта.

ResourceEditor 011.jpg

Для папок и ресурсов по нажатию правой кнопки мыши доступно контекстное меню:

ResourceEditor 012.jpg
Название Описание
New Создать новый ресурс в выбранной директории.
Edit Перейти в режим редактирования ресурса.
Open in External Program Открыть ресурс в сторонней программе.
Cut Вырезать ресурс.
Copy Копировать ресурс.
Delete Удалить ресурс.
Rename Переименовать ресурс.
Sort by Сортировать элементы дерева ресурсов.
Refresh Обновить дерево ресурсов.
Properties Открыть свойства ресурса.


Редакторы

Для каждого вида ресурса имеется специализированный редактор. Другими словами, редактор ресурсов представляет собой сборник из множества редакторов:

Редактор типов объектов

Редактор типов объектов предназначен для настройки типов, объекты которых будут размещаться в редакторе карт. Типы объектов хранятся в .type файлах.

Перейти к обзору редактора типов объектов

Редактор объектов


Редактор физических моделей

Редактор физических моделей предназначен для настройки физического поведения объектов. С помощью физической модели описываются свойства объекта, которые будут использоваться при расчете симуляции физики, столкновений, трансформации. Физические модели хранятся в .physics файлах.

Перейти к обзору редактора физических моделей

Редактор физических моделей


Редактор систем частиц

Редактор систем частиц предназначен для настройки эффектов. Системы частиц хранятся в .particle файлах.

Перейти к обзору редактора систем частиц

Редактор систем частиц


Редактор настройки 3D моделей

Редактор настройки 3D моделей предназначен для настройки созданных в процессе импорта 3D моделей. 3D модели хранятся в .mesh файлах. Редактор позволяет поменять масштаб, подвинуть центр модели, поменять материалы, посчитать уровни детализации (LOD), настроить анимацию, которая хранится в .skeleton файлах.

Перейти к обзору редактора моделей

Редактор для настройки моделей


Редактор материалов

Редактор материалов предназначен для настройки материалов 3D моделей. Материалы хранятся в .highMaterial файлах.

Перейти к обзору редактора материалов

Редактор материалов


Редактор пользовательских интерфейсов

Редактор пользовательских интерфейсов предназначен для настройки элементов, экранов пользовательского интерфейса проекта. Пользовательские интерфейсы хранятся в .gui файлах.

Перейти к обзору редактора интерфейсов

Редактор пользовательских интерфейсов


Редактор описаний шрифтов

Редактор описаний шрифтов предназначен для настройки параметров отображения шрифтов в движке. Описания шрифтов хранятся в .fontDefintion файлах.

Перейти к обзору редактора описания шрифтов

Редактор описаний шрифтов


Редактор импорта 3D моделей

Редактор импорта моделей предназначен для импорта 3D моделей из других форматов в формат движка. Настройки импорта хранятся в .modelImport файлах.

Перейти к обзору редактора импорта моделей

Редактор импорта моделей


Аудио/видео проигрыватель

В этом редакторе проигрываются звуковые и видео файлы. Для них в окне Properties доступны две операции:

  1. Кнопка Play позволяет проиграть выбранного ресурса.
  2. Флажок Loop Play позволяет зациклить проигрывание выбранного ресурса.

Рекомендуется использовать формат файлов .ogg для аудио и .ogv для видео. Подробнее об этих форматах написано здесь.

Для преобразования видео в формат .ogg в SDK движка есть специальный конвертер, который можно найти в папке SDK\Tools\Video\ffmpeg2theora

Проигрыватель аудио-видео данных


Просмотрщик текстур

Просмотрщик текстур позволяет просматривать текстуры и конвертировать их в другие форматы. Для конвертации нужно кликнуть по текстуре в окне ресурсов правой кнопкой мыши и в контекстном меню выбрать пункт "Convert to...". Поддерживаемые форматы:

  • TGA,
  • JPG,
  • PNG,
  • DDS-TXT1,
  • DDS-TXT5,
  • DDS-3Dc (Normal Map),
  • DDS-(A)RGB.
Просмотрщик текстур


Настройка окон редактора

Редактор позволяет настраивать положение окон. Для перемещения окна нужно потянуть его в нужную сторону за заголовок, удерживая левую кнопку мыши.

ResourceEditor 023.jpg

Настройки редактора

Окно настроек можно открыть через пункт меню Tools. Настройки поделены на несколько вкладок.

Общие настройки

Во вкладке General находятся общие настройки редактора.

Вкладка General
Опция Описание
General
General Background Color Основной цвет фона редактора.
Hide Directories And Files Список скрытых директорий и файлов. Директории и файлы из этого списка отображаются серым цветом в окне ресурсов.
Show Splash Screen At Startup Включить/выключить всплывающий экран при загрузке редактора.
Sound Volume Громкость звука.
Lighting
Default Ambient Light Яркость источника света. Задается как цвет.
Default Light Diffuse Color Цвет источника света по умолчанию.
Default Light Direction Направление источника света по умолчанию.
Default Light Specular Color Цвет отражения источника света по умолчанию.
Run Simulation
Run Simulation Parameters Командная строка для запуска симуляции (Game.exe).
Viewport
Invert Mouse Wheel Включить/выключить инвертирование колесика мыши.
Max Frames Per Second In Active State Максимальная частота кадров в активном состоянии редактора.
Max Frames Per Second In Inactive State Максимальная частота кадров в неактивном состоянии редактора.

Настройки пользовательского интерфейса

Во вкладке User Interface можно настроить шрифты редактора.

Вкладка User Interface
Опция Описание
Fonts
The Font of Context Menu Шрифт контекстного меню.
The Font of Form Шрифт форм ввода.
The Font of Main Menu Шрифт главного меню.
The Font of Property Grid Шрифт таблиц свойств.
The Font of Tree Control Шрифт элементов дерева.

Настройки камеры

Во вкладке Camera находятся настройки камеры.

Вкладка Camera
Опция Описание
Keyboard
Keyboard Movement Fast Speed Скорость быстрого перемещения камеры (с нажатой клавишей Shift) при управлении с клавиатуры.
Keyboard Movement Speed Скорость перемещения камеры в нормальном режиме при управлении с клавиатуры.
Keyboard Rotation Fast Speed Скорость поворота быстрого камеры (с нажатой клавишей Shift) при управлении с клавиатуры.
Keyboard Rotation Speed Скорость поворота камеры в нормальном режиме при управлении с клавиатуры.
Mouse
Mouse Movement Fast Sensitivity Чувствительность перемещения камеры в ускоренном режиме (с нажатой клавишей Shift) при управлении с помощью мыши.
Mouse Movement Sensitivity Чувствительность перемещения камеры в нормальном режиме при управлении с помощью мыши.
Mouse Rotation Horizontal Sensitivity Чувствительность поворота камеры при управлении с помощью мыши.
Mouse Rotation Vertical Sensitivity Чувствительность поворота камеры при управлении с помощью мыши.
Settings
Far Clip Distance Дальность видимости объектов.
Field of View Угол обзора.
Near Clip Distance Ближнее расстояние видимости объектов. Объекты, расположенные ближе указанного радиуса, не отображаются.

Настройки инструмента трансформации

Во вкладке Transform Gizmo настраиваются параметры инструмента трансформации объектов.

Вкладка Transform Gizmo
Опция Описание
General
Line Thickness Толщина линий.
Rotation Sensitivity Чувствительность при вращении объекта.
Shadow Intensity Интенсивность тени.
Size (pixels) Размер инструмента (в пикселях).
Snapping
Movement Snapping Шаг при перемещении объекта (в метрах).
Rotation Snapping (degrees) Шаг при повороте объекта (в градусах).
Scale Snapping (%) Шаг при масштабировании объекта (в процентах).