Документация/Статьи/Обзор редактора описания шрифтов

From NeoAxis 3D Engine Wiki

Jump to: navigation, search
Перейти на уровень выше

Contents

Обзор

Редактор описания шрифтов является составной частью редактора ресурсов. Позволяет добавить в проект шрифты, для дальнейшего их использования в пользовательском интерфейсе (UI).

Редактор описания шрифтов

Существуют два способа импортировать шрифты:

  • использование встроенного в движок редактора для импорта и настройки TrueType шрифта в формате .ttf,
  • использование сторонних утилит для подготовки файла с текстурой шрифта и файла описания шрифта.

Оба способа имеют плюсы и минусы. Первый способ обычно более предпочтителен для шрифтов с небольшим количеством символов. Плюсом первого способа является попиксельная точность, т.к. движок генерирует текстуру с символами на лету для выбранноого разрешения экрана. Второй способ предпочтителен для шрифтов с большим количеством символов, например для шрифтов с иероглифами. Во втором способе текстура с символами подготавливается заранее.

Параметры

Настройки редактора можно открыть через меню Tools -> Options или нажав кнопку Options на панели инструментов. В появившемся окне необходимо выбрать вкладку Font Definition.

FontDefinitionEditor 02.jpg
Свойство Описание
General
Background Color Цвет фона в рабочем окне.
Preview Text Текст отображаемый на экране шрифтом, который настраивается.

Импорт шрифтов с расширением .ttf

Создание файла описания шрифта

Для начала нужно скопировать шрифт в формате .ttf в папку "Data\Fonts". Данный формат используется для хранения TrueType шрифтов. Далее нужно в главном меню выбрать пункт File -> New -> Font Definition. В появившемся окне нужно указать имя и язык соответствующий шрифту. Будет создан новый файл описания шрифта, но он будет пуст, пока к нему не будет привязан файл шрифта — параметр TrueTypeFontName. Чтобы отредактировать файл описания (.fontDefinition), нужно дважды щелкнуть по нему.

Параметры файла описания шрифта

Параметры файла описания шрифта находятся в окне свойств.

FontDefinitionEditor 03.jpg
Параметр Описание
_General
FileName Путь к файлу описания шрифта. Настраивается при создании файла.
Type Тип шрифта, который использует данное описание. Настраивается при создании файла.
Characters
CharactersRanges Набор используемых символов в виде списка диапазонов. Каждый диапазон содержит начальный и конечный номера символов.
CharactersString Набор используемых символов в виде строки.
TrueType
AdvanceMultiplier Множитель расстояния между символами при их отображении. Значение по умолчанию — 1, допустимый диапазон значений от 0.5 до 2.
DrawOffsetY Смещение символов по вертикальной оси.
InGame3DGuiHeightInPixels Высота шрифта в пикселях, используемая во внутреигровом 3D-интерфейсе.
SizeMultiplier Масштабирование размеров шрифта по осям X и Y. Допускается пропорциональное и непропорциональное изменение размера.
TextureIndentBetweenCharacters Свободное расстояние между символами на текстуре. Если указать слишком малое значение, то при отображении символов могут быть заметны пиксели соседних символов. Слишком большое значение ведет к нерациональному использованию площади текстуры.
TextureSize Размер текстуры. Т.к. для шрифтов используются квадратные текстуры, то указывается одно значение. Позволяет выбрать между значениями 512, 1024 или 2048 пикселей.
TrueTypeFontName Путь к файлу шрифта, для которого создан данный файл описания. Допускается использовать только TrueType шрифты (с расширением .ttf). Для выбора файла шрифта необходимо выделить свойство и нажать на кнопку "..." справа.

Просмотр текстуры

Сгенерированную текстуру можно увидеть, выбрав ее в списке текстур внизу окна свойств.

Выбор текстуры для просмотра

Создание шрифта с помощью генератора шрифтов

Помимо TrueType шрифтов, движок имеет возможность импортировать текстуры со шрифтами из сторонних утилит. Примером такой утилиты служит Bitmap Font Generator. Найти ее можно в папке "SDK\Tools\Fonts\BitmapFontGenerator"'.

FontDefinitionEditor 05.jpg

Создание текстур

После запуска Bitmap Font Generator, следует зайти в настройки генерации текстур. Настройки поделены на две части. Одна часть находится в окне, вызываемом через меню Options -> Font Settings. В нем необходимо указать используемый шрифт и нажать на кнопку OK.

FontDefinitionEditor 06.jpg

Настройки экспорта расположены в другом окне. Для его открытия нужно выбрать в меню Options пункт Export Options. В открывшемся окне необходимо установить формат выходного файла: XML. После этого нажать кнопку OK. Также в данном окне настраиваются такие параметры как отступ между символами, размер текстуры, ее формат и другое.

FontDefinitionEditor 07.jpg

Теперь в рабочей области главного окна утилиты нужно выбрать используемые символы. Кроме того, можно указать используемые наборы символов в списке в правой части окна.

FontDefinitionEditor 08.jpg

Далее, чтобы сохранить текстуру со шрифтом, в меню Options необходимо выбрать пункт Save bitmap font as....

При сохранении шрифта, для имени файла можно использовать только английские буквы, а также цифры.

Преобразование текстуры в описание шрифта

Теперь нужно создать описание шрифта на основе текстуры. Для этого в SDK входит специальная утилита BitmapFontGeneratorToNeoAxisConverter. Она находится в директории "SDK\Tools\Fonts\BitmapFontGeneratorToNeoAxisConverter".

После запуска утилиты, необходимо указать файл со шрифтом в формате .fnt. Для этого нужно нажать на кнопку "..." и выбрать созданный ранее файл шрифта.

FontDefinitionEditor 09.jpg

После того как файл выбран, следует нажать на кнопку Convert.

FontDefinitionEditor 10.jpg

Когда генерация описания шрифта завершится, будет показано следующее сообщение:

FontDefinitionEditor 11.jpg

Это значит, что создание шрифта завершено. Посмотреть получившийся шрифт можно в редакторе ресурсов.

FontDefinitionEditor 12.jpg

Теперь шрифт, созданный с помощью Bitmap Font Generator, готов к использованию.